Language:

Homepage » DLL Q & A

Services.exe Excessive High Cpu

Download Now


Services.exe High Cpu

DEBRA HARDING asked on January 20, 2013. Status: Answered & Closed.

Services.exe Excessive High Cpu

» I have this issue, please tell me how to fix it, thanks in advanced.


Best Answer

» Scan for malware infection or viruses like Trojan:Win32/Comame. You might not notice that your computer has malware installed, nowadays malware has become one of the main online threats to the computer, most of them can be installed through freeware bundles without users notice, and it has been proved that malware is able to damage system process such as sxstrace.exe, if your computer have anti-virus program installed, run a full scan over your system immediately. But after removing the malware, you need to check the dll files for sure, because some associated dll files must have been corrupted or damaged in this process,

therefore, DLL Suite is recommended here. It is a comprehensive dll file error fixer. It has one tool called "Fix EXE Virus", specially targeted to fix virus infection problem, which is Excessive High Cpu usage in this case.

NICHOLAS GIFFIN replied on January 24, 2013


All Answers:

  1. GEORGINA TOTAH replied on January 20, 2013: » Try the below methods and check for the results:

    Method 1:

    Check if the issue persists in safe mode, to boot the computer in safe mode:

    a. Restart the computer and press and hold F8 key (Press and hold f8 key before the windows logo).

    b. From the advanced boot option select 'Safe mode'.

    Method 2:

    If the issue does not persist in safe mode, there might be some third-party application causing the issue. To narrow down you may follow the below method:

    Boot the computer in clean boot and check if the issue still persists. Below link will help you in booting the computer in clean boot: How to configure Windows XP to start in a "clean boot" state: http://support.microsoft.com/kb/310353

    f the issue does not persist you may continue with step 2 from the above link.

    Make sure you reset the computer to normal mode from the section "Steps to configure Windows to use a Normal startup state"

  2. DEBRA HARDING replied on January 21, 2013: » The problem does not persist in safe mode or clean boot. So it sounds like you're saying it's some third party application. Just not sure what you want me to do by continuing "with step 2 from the above link." Do you want me to slowly add-back applications, rebooting between each one until I find the culprit? Seems laborious but will do so if that's the best/only way to proceed.

  3. KAREN FLAGG replied on January 21, 2013: » I would check the status of Services. Click on the Start button and select Control Panel, Administrative Tools, Services. Locate Security Accounts Manager in the list and check that the StartUp type is Automatic. If it is not set to Automatic right click and select Properties, General tab. There is a box after StartUp type. The options are available on a drop down by clicking on the arrow down to the right of the box. After making the change click on Apply and OK. Restart the computer and check whether it has started.

    If it has not started you will need to check the service which the Security Accounts Manager service depends on. This service is Remote Procedure Call which should also be set to Automatic and should have started. Change the StartUp type if necessary.

  4. HENRY HARDIN replied on January 22, 2013: » I don't know how helpful this will be... but I experienced a similar problem with an XP machine (Pentium 4/300 ghz/2.5 meg. ram. To whit: services.exe was using nearly 100% of cpu time. It would slowly 'ramp up' over a period of a minute or three after each re-start until the machine became slow as molasses.

    From another post elsewhere, the suggestion was made to check all Devices to ensure that none showed a problem. Did that, and all devices were showing to be operating properly. However, I did notice that the 'wheel function' of the Logitech wired (not wireless) mouse was not working. Checking the 'Mouse Properties' from the Control Panel displayed no 'wheel function' option.

    I uninstalled the mouse driver, did a restart, and went back to the Mouse Properties on the Control Panel and did a mouse driver update. Now the Mouse Properties showed the wheel function. Set the wheel function and the mouse now worked fine. I had the "Task Manager Processes" window open to monitor Services.exe. As soon as the mouse problem was rectified, services.exe returned to minimal cpu commitment and the machine returned to optimal operation.

    The conclusion: if one has a problem with services.exe, one might take a good, close look at the proper function of devices that work, in one way or another, through the 'Plug and Play' feature of XP. I am no guru, just a fellow with a lot of "living with Microsoft" behind me.

DLL Q & A You Might Like:

  1. Exe Default Program To Firefox »
  2. Exe Files Open With Adobe Reader »
  3. Installing WinHelp32.exe On Windows 8 Pro »
  4. Windows Media Center Broken And EhRec.exe Taking 50% Of CPU »
  5. Unable To Download Exe Files »
  6. Unable To Run Autorun.exe For Software DVD »